注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

金融IT小鸿的博客

致力于金融IT行业

 
 
 

日志

 
 
关于我

Organize the world's information I care about and share it with other people! Change the Financial Industry through Information Technology! 爱互联网,爱金融, 爱分享,爱运动, 也爱偶尔胡思乱想! 我是金融IT小鸿

网易考拉推荐

整合flash builder 4和Eclipse  

2010-01-31 22:58:58|  分类: Flash相关 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
最近准备搞一下flex方面的东西,下了个最新版的flash builder 4.官方下载地址
注册一个账号,选择Flash Builder 4 Plugin for Eclipse下的下载地址,然后就是傻瓜式安装。安装完成后就可以直接使用了。这个对于之前机器上没有安装Eclipse和JDK的初学者很方便,整个开发平台及其所需的各种环境都在一起了。但是这给人一种感觉就是,Eclipse好像是放在了flash builder之下,其实是flash builder作为一个插件运行在Eclipse平台上。同时,如果你之前已经安装了Eclipse和JDK,那就会造成冗余和重复安装,非常不custom,以下就是把flash builder作为插件安装的方法:

    1、需要Eclipse是3.4以上版本,下载地址http://download.actuatechina.com/eclipse/technology/epp/downloads/release/ganymede/SR2/eclipse-java-ganymede-SR2-win32.zip 才能兼容flash builder 4。

    2、按照开头介绍的下载地址或者自己搜,下载Flash Builder 4 Plugin for Eclipse,傻瓜安装完成后,找到flexbuilder目录下的eclipse文件夹。将其复制到自定义的插件安装目录下,比如我的就是D:\eclipse\MyPlugins\Flex。

    3、将flexbuilder里的sdks文件夹(应该是在flexbuilder的子目录里,我写这篇文章的时候已经将flexbuilder卸载,sdks里面有两个文件夹:3.4.1和4.0.0)复制出来,不要放在flexbuilder目录下。然后就可以卸载flexbuilder 4了。

   4、然后配置一下link文件,Eclipse中增添了dropins自定义插件安装方法,其实是之前的links方法的增强版。可以参考http://nlslzf.javaeye.com/blog/262005。我还是按照links的方法配置,在dropins文件夹里新建一个Flex.link,文件名可以自己取。里面指明插件的路径,我的是path=D:/eclipse/MyPlugins/Flex。

   5、最后启动Eclipse,打开Window -- Preferences -- Flash Builder -- 已安装的Flex  SDK,添加步骤三中复制出的sdks。

注:
1、flash builder 4的序列号上搜就可以了,下面提供一个我搜到的序列号:
1424-4008-9664-3602-3439-171* 最后一位0—9应该都可以,总有一个能用的!
 
2、初次运行,会出现因为内存不足造成eclipse崩溃退出。这时只需设置一下eclipse根目录下的
eclipse.ini文件的配置参数就能轻松搞定。
 
我的eclipse.ini文件是这样设置的,跑起来没问题:

-framework plugins\org.eclipse.osgi_3.4.3.R34x_v20081215-1030.jar -vmargs -Xms128M -Xmx512M -XX:PermSize=256M -XX:MaxPermSize=512M

配置完成,祝大家编程愉快!

ps上述的配置方法貌似已经过时了,网上说Adobe公司好像在四月一日愚人节禁用了所有flex4 Beta版的序列号。现在已经有了Flash Builder Premier的试用版。大家可以直接访问这里,下载Flash Builder 4的Eclipse 插件版,要求Eclipse 3.4以上版本。安装的时候指定一下Eclipse的安装目录就OK了。
现在貌似序列号网上找的都不能用了,因为Adobe采用了联网验证的方式,不过大家可以登录这里免费申请一个Flash Builder 4的序列号。我按照学生申请的,成功了!

Update 2011-05-10 :现在Adobe已经推出了Flash Builder 4.5 Premium, 而且还没有提供插件版的下载。而且是收费的,对一些特殊群体,如学生,教师提供折扣。我目前用的是Flash Builder 4.5 Preview的,是免费的!大家仍然可以登录这里免费申请Flash Builder 4.5 Standard的序列号。
  评论这张
 
阅读(10969)| 评论(7)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017